martes, 14 de diciembre de 2010

Migrando de Windows 7 a Ubuntu 10.10


Por el mes de junio compre mi portátil, un Acer Aspire 4535 que viene equipada con una tarjeta de vídeo ATI Radeon HD3200. Decidí dejar mi portátil tal cual me lo entregaron por al menos 6 meses, es decir; con el windows 7 preinstalado.

Para compensar un poco me instale una máquina virtual con la distribución de Ubuntu 9.04 y todo de maravilla.

Como ya se cumplió el tiempo que tenía destinado para desinstalar el windows 7 me puse manos a la obra para migrar completamente hacia mi sistema y distribución favorita Linux, Ubuntu.

Para la migración saque copias de respaldo de:
- La carpeta Mis Documentos
- La carpeta Mi Música
- La carpeta Mis Imágenes
- No tenía videos así que no la toque
- Copia de algunos archivos y carpetas que tenía esparcidos en el escritorio
- Copia de algunos archivos que tenía en varias carpetas del disco C
- Como no quería perder los marcadores del navegador los exporte en formato html y JSON

Hechas las copias y verificadas, procedí a reiniciar/bootear el portátil con el disco de Ubuntu 10 en la unidad de cd y cuando esta cargo se le dio instalar. El resto solo fue esperar, configurar el idioma, las claves y listo.

Ya con mi Ubuntu funcionando procedí a "plantar" nuevamente los archivos en sus respectivas carpetas, es decir, documentos, imagenes, etc; y cuando abrí mi Mozilla importe los marcadores y todo muy bien.

La única dificultad con la que me he topado (por ahora) ha sido con la configuración de la tarjeta de video que es una ATI Radeon HD3200 Graphics pues al instalar los drivers se mejora la resolución de la pantalla pero en algunas ocasiones mi pantalla parpadea (no es frecuente, una que otra vez cada hora) y lo que si es molesto es que al abrir algunos menús de listas éstos aparecen como si estuvieran en cursiva y fuera de la posición normal "desenfocados diría yo" (no se si me explico), la terminal y algunos programas los debo maximizar para que queden normal.

He buscado en varios foros y he probado lo allí expuesto pero no ha funcionado. Alguno de ustedes tiene la solución?? Si es así me gustaría que me la dieran a conocer.

Debo aclarar que si desinstalo el controlador de la tarjeta todo anda con normalidad, pero bueno, quiero sacarle el máximo provecho a mi pequeña máquina.

Estos son algunos datos para aquellos que quizás me puedan colaborar:

Linux manuel-Aspire-4535 2.6.35-23-generic-pae #41-Ubuntu SMP Wed Nov 24 10:35:46 UTC 2010 i686 GNU/Linux

Configuración del xor.conf:
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "0-LVDS"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
Option "PreferredMode" "1366x768"
Option "TargetRefresh" "60"
Option "Position" "0 0"
Option "Rotate" "normal"
Option "Disable" "false"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "Monitor-LVDS" "0-LVDS"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection